$re = '/\d{2}\/\d{2}\/\d{2}(?:(?!\d{2}\/\d{2}\/\d{2}).)*string.*?\d{2}\/\d{2}\/\d{2}/ms';
$str = '01/20/20
string
01/21/20
01/20/20
this isn\'t the phrase you\'re looking for
01/21/20
string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);