import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "name:\\s+['\"]?AVP_VERSION['\"]?[\\s,]+value:\\s+['\"]?(?<currentValue>[_\\-\\.\\w]+)['\"]?";
final String string = "env: [ name: AVP_VERSION, value: 1.18.1 ]\n"
+ " image: registry.access.redhat.com/ubi8\n"
+ " env:\n"
+ " - name: AVP_VERSION\n"
+ " value: \"1.18.0\"\n"
+ " command: [ sh, -c ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}