# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"name:\s+['\"]?AVP_VERSION['\"]?[\s,]+value:\s+['\"]?(?<currentValue>[_\-\.\w]+)['\"]?"
test_str = ("env: [ name: AVP_VERSION, value: 1.18.1 ]\n"
" image: registry.access.redhat.com/ubi8\n"
" env:\n"
" - name: AVP_VERSION\n"
" value: \"1.18.0\"\n"
" command: [ sh, -c ]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.