Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?
/
gm
Input 1
1
New
env: [ name: AVP_VERSION, value: 1.18.1 ] image: registry.access.redhat.com/ubi8 env: - name: AVP_VERSION value: "1.18.0" command: [ sh, -c ]