package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^.]+$`)
var str = `\\share\david\test\test.doc
\\sharre\david.jones\test\test.doc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}