using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rr\d---sn-\w{8}.googlevideo.com";
string input = @"||rr3---sn-hp57yne7.googlevideo.com^$important
||rr3---sn-oguelnlz.googlevideo.com^$important
||rr5---sn-hp57knd6.googlevideo.com^$important";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}