import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rr\\d---sn-\\w{8}.googlevideo.com";
final String string = "||rr3---sn-hp57yne7.googlevideo.com^$important\n"
+ "||rr3---sn-oguelnlz.googlevideo.com^$important\n"
+ "||rr5---sn-hp57knd6.googlevideo.com^$important";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}