const regex = /rr\d---sn-\w{8}.googlevideo.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rr\\d---sn-\\w{8}.googlevideo.com', 'gm')
const str = `||rr3---sn-hp57yne7.googlevideo.com^\$important
||rr3---sn-oguelnlz.googlevideo.com^\$important
||rr5---sn-hp57knd6.googlevideo.com^\$important`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}