# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?xs)\n"
r"(?<!')(?:'{2})*\B('\b[^'\\]*(?:(?:\\.|\b'\b)[^'\\]*)*') # Single quoted string literal\n"
r"| # or\n"
r"(?<!\")(?:\"{2})*\B(\"\b[^\"\\]*(?:(?:\\.|\b\"\b)[^\"\\]*)*\") # Double quoted string literal")
test_str = ("I am \"looking for\" a way that doesn't break: \"Lorem\n"
"ipsum\\\" AAAAA\" in this case. Or this AAAAA case. Or this 'AAAAA' case.\n"
"Isn't this annoying?\n"
"I used to love the song Space Truckin'. It is 'AAAAA'.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.