# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)/\1 & \3 \2/gi;t' <<< "N MONON AVE FRANCESVILLE W YELLOW ST"