package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)`)
var str = `N MONON AVE FRANCESVILLE W YELLOW ST`
var substitution = "\1 & \3 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}