use strict;
my $str = 'N MONON AVE FRANCESVILLE W YELLOW ST';
my $regex = qr/(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)/ip;
my $subst = '\\1 & \\3 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";