$re = '/(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)/i';
$str = 'N MONON AVE FRANCESVILLE W YELLOW ST';
$subst = "\1 & \3 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;