const regex = new RegExp('http(?=:\\/\\/(www\\.)?(google|sougou))', 'gm')
const str = `fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com`;
const subst = `https`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);