use strict;
my $str = 'fasuehttp://www.google.comfasdfhttp://www.baidu.comfasdhttp://sougou.comsfdhttp://www.zhihu.com';
my $regex = qr/http(?=:\/\/(www\.)?(google|sougou))/mp;
my $subst = 'https';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";