using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A.*?[\n\r](?=&)";
string input = @"Comments & Stuff
Comments & Stuff
&HEAD CHID='PBD', TITLE='Tools'/Comments & Stuff
Comments & Stuff
Comments & Stuff
&TIME T_BEGIN=0, T_END=60/Comments & Stuff
Comments & Stuff
Comments & Stuff";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}