$re = '/(?<=\K1)....1/';
$str = '001110000100001100001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);