use strict;
my $str = '0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD';
my $regex = qr/^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}