import Foundation
let pattern = #"^(?:[0][x][0-9A-F]{2}[,]\s){7}[0][x][0-9A-F]{2}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0x28, 0x30, 0x57, 0x45, 0xD4, 0xCD, 0x0F, 0xAD"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)