using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(ref|doc|term):`([^`]+)\s?<([^:`]+):([^:`]+)>`";
string input = @"This are :ref:`external references<python:reference>` with a :doc:`custom title <python:index>`.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}