re = /:(ref|doc|term):`([^`]+)\s?<([^:`]+):([^:`]+)>`/m
str = 'This are :ref:`external references<python:reference>` with a :doc:`custom title <python:index>`.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end