# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[^:]+:){3}([^:]+).*/\1/gm;t' <<< "arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
"