use strict;
my $str = 'arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
';
my $regex = qr/^(?:[^:]+:){3}([^:]+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";