import Foundation
let pattern = #"^(?:[^:]+:){3}([^:]+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)