$re = '/(\S+)(?:\s+\(\S+\))/m';
$str = 'ACM-24-01000 (ACM/KHCTAC1), LIN-24-01000 (LIN/LINR34), CBN-01001-24 (CBN/CBNE11)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);