using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((one|two|three)\s.*?)((four|five|six)\s.*?)((seven|eight|nine)\s.*)";
string input = @"one two three four five six seven eight nine
two three four six seven eight";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}