# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*<VirtualHost\s+[^>]*>\s*ServerName\s+(?P<ServerName>\S+)\s*DocumentRoot\s+(?P<DocumentRoot>.+?)\s*</VirtualHost>"
test_str = ("# Virtual Hosts\n"
"#\n"
"# Required modules: mod_log_config\n\n"
"# If you want to maintain multiple domains/hostnames on your\n"
"# machine you can setup VirtualHost containers for them. Most configurations\n"
"# use only name-based virtual hosts so the server doesn\\'t need to worry about\n"
"# IP addresses. This is indicated by the asterisks in the directives below.\n"
"#\n"
"# Please see the documentation at \n"
"# <URL:http://httpd.apache.org/docs/2.4/vhosts/>\n"
"# for further details before you try to setup virtual hosts.\n"
"#\n"
"# You may use the command line option \\'-S\\' to verify your virtual host\n"
"# configuration.\n\n"
"#\n"
"# Use name-based virtual hosting.\n"
"#\n"
"##NameVirtualHost *:80\n"
"#\n"
"# VirtualHost example:\n"
"# Almost any Apache directive may go into a VirtualHost container.\n"
"# The first VirtualHost section is used for all requests that do not\n"
"# match a ##ServerName or ##ServerAlias in any <VirtualHost> block.\n"
"#\n"
"##<VirtualHost *:80>\n"
" ##ServerAdmin webmaster@dummy-host.example.com\n"
" ##DocumentRoot \"D:/xampp/htdocs/dummy-host.example.com\"\n"
" ##ServerName dummy-host.example.com\n"
" ##ServerAlias www.dummy-host.example.com\n"
" ##ErrorLog \"logs/dummy-host.example.com-error.log\"\n"
" ##CustomLog \"logs/dummy-host.example.com-access.log\" common\n"
"##</VirtualHost>\n\n"
"##<VirtualHost *:80>\n"
" ##ServerAdmin webmaster@dummy-host2.example.com\n"
" ##DocumentRoot \"D:/xampp/htdocs/dummy-host2.example.com\"\n"
" ##ServerName dummy-host2.example.com\n"
" ##ErrorLog \"logs/dummy-host2.example.com-error.log\"\n"
" ##CustomLog \"logs/dummy-host2.example.com-access.log\" common\n"
"##</VirtualHost>\n\n\n\n"
"##<VirtualHost *:8080>\n"
" ##ServerName CI1\n"
" ##DocumentRoot D:\\xampp\\htdocs\\codeigniter_1\\public\n"
"##</VirtualHost>\n\n"
"<VirtualHost *:8080>\n"
" ServerName CI2\n"
" DocumentRoot D:\\xampp\\htdocs\\codeigniter_2\\public\n"
"</VirtualHost>\n\n"
"<VirtualHost *:8080>\n"
" ServerName CI3\n"
" DocumentRoot D:\\xampp\\htdocs\\codeigniter_3\\public\n"
"</VirtualHost>\n"
"<VirtualHost *:8080>\n"
" ServerName CI3\n"
" DocumentRoot D:\\Embedded Spaces and spaces at end of line\\htdocs\\codeigniter_3\\public \n"
"</VirtualHost>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.