const regex = /^[a-zA-Z0-9]+([\-]?)+([\._]?[a-zA-Z0-9\-])+([\._]?)*([a-zA-Z0-9])@[a-zA-Z0-9\-]([\._]?[a-zA-Z0-9\-])*(\.\w{2,3})+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]+([\\-]?)+([\\._]?[a-zA-Z0-9\\-])+([\\._]?)*([a-zA-Z0-9])@[a-zA-Z0-9\\-]([\\._]?[a-zA-Z0-9\\-])*(\\.\\w{2,3})+$', '')
const str = `i_s-.o.--m_e@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}