$re = '/(&[a-z]*;)*(?: )*<[^>]*>/m';
$str = '<p>ri irrjor ir <b>jir ire ire i iroi </p>\\n
<p> </p>
<p> dsada asdsad </p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);