Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[ \t]*(\+|\-)?[ \t]*(\d*\.?\d+(E[\+|\-|\d]\d*)?)
/
g
Input 1
1
New
4.948601281E-4 34.6 12 23E+4 12.45E5 -12.34E-5i 4.948601281E-4-11.34E-4i