# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(["])(?:(?!\1|"").|"".)*\1/Subbed/g;t' <<< "Hello Colm \"This is a test\"\"\\\"
\"This is also an NL test\"
'And this has an escaped quote don\'t in it ' Blue Boy
\"This has a single quote ' but doesn\' end the quote as it started with double quotes\"
\"\"\"line spanning with escaped quote at the end of a line\"\"\"
\"\"\"\"
\"Foo Bar\" \"Another Value\" something else"