use strict;
my $str = 'Hello Colm "This is a test""\\\\"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes"
"""line spanning with escaped quote at the end of a line"""
""""
"Foo Bar" "Another Value" something else';
my $regex = qr/(["])(?:(?!\1|"").|"".)*\1/p;
my $subst = 'Subbed';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";