#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)#(?=(?:[^"'`]*"[^"'`]*")*(?:[^"'`]*'[^"'`]*')*(?:[^"'`]*`[^"'`]*`)*[^"'`]*$)"
Local $sString = " #somecomment" & @CRLF & _
" # some comment" & @CRLF & _
""#not a commnet" #another comment" & @CRLF & _
" '#not a comment'" & @CRLF & _
" jquery_code = "$('#some-identifier')[0].click()"#yet a comment, but the identifier :(" & @CRLF & _
"jquery_code = '$("#some-identifier")[0].click()'" & @CRLF & _
"# just another comment" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")