import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(?=(?:[^\"'`]*\"[^\"'`]*\")*(?:[^\"'`]*'[^\"'`]*')*(?:[^\"'`]*`[^\"'`]*`)*[^\"'`]*$)";
final String string = " #somecomment\n"
+ " # some comment\n"
+ "\"#not a commnet\" #another comment\n"
+ " '#not a comment'\n"
+ " jquery_code = \"$('#some-identifier')[0].click()\"#yet a comment, but the identifier :(\n"
+ "jquery_code = '$(\"#some-identifier\")[0].click()'\n"
+ "# just another comment\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}