package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)"`)
var str = `Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,"defaultMsg":"Updated VM hostname" asd asd ,"userName":"abc@abc.com", ada`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}