re = /(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)"/m
str = 'Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,"defaultMsg":"Updated VM hostname" asd asd ,"userName":"abc@abc.com", ada'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end