$re = '/P(.*\+)/m';
$str = 'Q-P-Q-Q
Q-P-Q+R-Q ';
$subst = "C$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;