$re = '/^(?!\s*$)(?!.*&#)[a-zA-Z0-9!@#$%&*+=[\]:;\',.?\s-]{1,32}$/m';
$str = 'dddddddddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);