re = /^(?!\s*$)(?!.*&#)[a-zA-Z0-9!@#$%&*+=[\]:;',.?\s-]{1,32}$/m
str = 'dddddddddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end