$re = '/(?:-*[^->])+/m';
$str = 'a--b--->c-d--->d--->e f--->&A#-foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);