re = /(?m)(?<=^info)(?:\r?\n){2}:(?:\r?\n){2}/mi
str = 'info
:
I went to Paris
xxx
yyy
zzz
info
:
I went to Italy
aaa
bbb
ccc
'
subst = ' : '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result