package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(:?[_a-z]+[_a-z0-9-]*)`)
var str = `px-3
py-1
rounded
@if(count($selected))
bg-orange-400
@else
bg-gray-200
@endif
text-white
text-center`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}