$re = '/^(?:http(?:s?):\/\/(?:www\.)?)?([A-Za-z0-9_:.-]+)\/?/m';
$str = 'https://github.com/
https://www.google.com/
https://192.168.1.100:8080/
localhost:8080/
http://153.168.26.5:2168/
http://localhost/phpmyadmin/sql.php
https://fonts.google.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);