#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*([0-9]{3}).*([0-9]{3}).*([0-9]{4})"
Local $sString = "970-800-6112" & @CRLF & _
"9708006112" & @CRLF & _
"(970) 800-6112" & @CRLF & _
"(970)800-6112" & @CRLF & _
"970.800.6112"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")