using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[^])(?:\P{Sentence_Terminal}|\p{Sentence_Terminal}(?!['""`\p{Close_Punctuation}\p{Final_Punctuation}\s]))*(?:\p{Sentence_Terminal}+['""`\p{Close_Punctuation}\p{Final_Punctuation}]*|$)";
string input = @"This is a sentence. This is another sentence.
df! bar. qolh ""foo.""
This is a malformed sentence ending.""another sentence starts.
This is MyEnum.Value1. lol!. ........ . . .eeeend
. . .eeeend";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}