import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "((http|https):)?(?(1)//|.)# protocol\n"
+ "(([\\.\\pL\\pN-]+:)?([\\.\\pL\\pN-]+)@)?# basic auth\n"
+ "(\n"
+ " ([\\pL\\pN\\pS\\-\\.])+(?(1)\\.?|\\.)([\\pL\\pN\\pS\\-\\.])+|((?(1)\\.?|\\.)([\\pL\\pN]|xn\\-\\-[\\pL\\pN-]+)+\\.?)# domain name\n"
+ " | \\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}# ip address\n"
+ ")\n"
+ "(:[0-9]+)?# port\n"
+ "(?:/ (?:[\\pL\\pN\\-._\\~!$&'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path\n"
+ "(?:\\?(?:[\\pL\\pN\\-._\\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# query\n"
+ "(?:\\# (?:[\\pL\\pN\\-._\\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# fragment\n"
+ "$";
final String string = "localhost.fhgf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}