# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
((http|https):)?(?(1)//|.)# protocol
(([\.\pL\pN-]+:)?([\.\pL\pN-]+)@)?# basic auth
(
([\pL\pN\pS\-\.])+(?(1)\.?|\.)([\pL\pN\pS\-\.])+|((?(1)\.?|\.)([\pL\pN]|xn\-\-[\pL\pN-]+)+\.?)# domain name
| \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}# ip address
)
(:[0-9]+)?# port
(?:/ (?:[\pL\pN\-._\~!$&'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path
(?:\?(?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# query
(?:\# (?:[\pL\pN\-._\~!$&'()*+,;=:@/?]|%[0-9A-Fa-f]{2})* )?# fragment
$
"""
test_str = "localhost.fhgf"
matches = re.search(regex, test_str, re.IGNORECASE | re.UNICODE | re.VERBOSE | re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.