re = /^
((http|https):)?(?(1)\/\/|.)# protocol
(([\.\pL\pN-]+:)?([\.\pL\pN-]+)@)?# basic auth
(
([\pL\pN\pS\-\.])+(?(1)\.?|\.)([\pL\pN\pS\-\.])+|((?(1)\.?|\.)([\pL\pN]|xn\-\-[\pL\pN-]+)+\.?)# domain name
| \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}# ip address
)
(:[0-9]+)?# port
(?:\/ (?:[\pL\pN\-._\~!$&'()*+,;=:@]|%[0-9A-Fa-f]{2})* )*# path
(?:\?(?:[\pL\pN\-._\~!$&'()*+,;=:@\/?]|%[0-9A-Fa-f]{2})* )?# query
(?:\# (?:[\pL\pN\-._\~!$&'()*+,;=:@\/?]|%[0-9A-Fa-f]{2})* )?# fragment
$/ixm
str = 'localhost.fhgf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end