re = /^(?|(AllowUsers.+?(?=\bbob\b))(\bbob\b)(.*)|(AllowUsers .*))$/m
str = 'AllowUsers richard
AllowUsers richard jeremy
AllowUsers james richard jeremy
AllowUsers jeremy
AllowUsers bob
AllowUsers bob billybob
AllowUsers billybob bob
AllowUsers billybob steve bob eric bobby
AllowUsers billybob bobby steve bob eric
AllowUsers richard bob
AllowUsers richard bob jeremy
AllowUsers bob james richard jeremy
AllowUsers bob jeremy
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end