# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:src|action|href)=[\'"]\K\/(?!\/)[^\'"]*/https:\/\/example.com$0/g;t' <<< "<img src=\"/relative/url/img.jpg\" />
<form action=\"/\">
<form action=\"/contact-us/\">
<a href='/relative/url/'>Note the Single Quote</a>
<img src=\"//site.com/protocol-relative-img.jpg\" />
"